1100 Mars Numbers (20)

People on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (< 100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

思路:

火星上的数字基数是13.

注意0的叫法

1-12={jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec}

更高位次13.26.39.52.....={tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou}

给火星数字转换成地球数字,给地球数字转换成火星数字

C++

#include<cstdio>
#include<iostream>
#include<string>
#include<map>
using namespace std;
//[0,12]火星文 
string unitDigit[13]={
	"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"
};
//13的[0,12]倍火星文
string tenDigit[13]={
	"tret","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"
};
string numToStr[170];
map<string,int> strToNum;
void init(){
	for(int i=0;i<13;i++){
		numToStr[i]=unitDigit[i];
		strToNum[unitDigit[i]]=i;
		numToStr[i*13]=tenDigit[i];
		strToNum[tenDigit[i]]=i*13;
	}
	for(int i=1;i<13;i++){
		for(int j=1;j<13;j++){
			string str=tenDigit[i]+" "+unitDigit[j];
			numToStr[i*13+j]=str;
			strToNum[str]=i*13+j;
		}
	}
}
int main(){
	init();
	int T;
	scanf("%d%*c",&T);
	while(T--){
		string str;
		getline(cin,str);
		if(str[0]>='0'&&str[0]<='9'){
			int num=0;
			num=stoi(str);
			cout<<numToStr[num]<<endl;
		}else{
			cout<<strToNum[str]<<endl;
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ysq96/article/details/81319047