7.25

1056 Mice and Rice (25)(25 分)提问

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N~P~ programmers. Then every N~G~ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N~G~ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N~P~ and N~G~ (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N~G~ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N~P~ distinct non-negative numbers W~i~ (i=0,...N~P~-1) where each W~i~ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...N~P~-1 (assume that the programmers are numbered from 0 to N~P~-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5
#include <cstdio>
#include <queue>
using namespace std;
const int maxn=1010;
struct mouse{
	int weight;
	int r;//排名 
}mouse[maxn];

int main()
{	
    queue<int> q;//放置本轮竞争者 
	int n,m,order;
	scanf("%d%d",&n,&m);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&mouse[i].weight);
	}

	for(int i=0;i<n;i++)
	{
		scanf("%d",&order);
		q.push(order);//全部入队  用序号代替这只老鼠 
	}
	int temp=n,group;
	while(q.size()!=1)//计算组数 有多少组进行比赛   剩下最后一只胜利的老鼠 
	{
		if(temp%m==0) group=temp/m;
		else group=temp/m+1;
		for(int i=0;i<group;i++)
		{
			int k=q.front();//k存放该组质量最大的老鼠的编号 
			for(int j=0;j<m;j++) 
			{
				if(i*m+j>=temp)//在最后一组老鼠数目不足ng时起作用 退出循环
		        break;
		        int front=q.front();//队首老鼠编号
				if(mouse[front].weight>mouse[k].weight)
				{
					k=front;
				}
				mouse[front].r=group+1;//比k老鼠的重量小 出局 
				q.pop();//这只老鼠出队 赢的老鼠已然记下他的序号  
			} 
			q.push(k);//叫出胜利老鼠入队 
		}
	temp=group;//group组老鼠晋级 下局总老鼠数目为group 
	}
	mouse[q.front()].r=1;
	for(int i=0;i<n;i++)
	{
		printf("%d",mouse[i].r);
		if(i<n-1) printf(" ");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Coding18/article/details/81210531
今日推荐