H - 连通分量 POJ - 3620 Avoid The Lakes DFS水题

H - 连通分量 POJ - 3620 

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

题意:N*M的地图上有K个湖,求最大连通分量(四连通)

DFS水题,把输入的湖泊入队,每次出队判断是否已经计算过这个湖, 没有的话就DFS搜索该连通块的大小,记录最大值

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <cmath>
#include <algorithm>
#include <string>
#include <map>
#include <stack>
#include <set>

using namespace std;
const int maxn=111;
int ma[maxn][maxn];
struct node
{
    int x,y;
};
queue<node>q;
int f[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
int ans=0;
int step=0;
int N,M,K;
void DFS(int x,int y)
{
    ans=max(step,ans);
    ma[x][y]=1;
    for(int i=0;i<4;i++)
    {
        int xx=x+f[i][0];
        int yy=y+f[i][1];
        if(xx<=0||yy<=0||yy>M||xx>N)continue;
        if(ma[xx][yy]==-1)
        {
            step++;
            ma[xx][yy]=1;
            DFS(xx,yy);
        }
    }
}
int main()
{
    //int N,M,K;
    while(~scanf("%d%d%d",&N,&M,&K))
    {
        memset(ma,0,sizeof(ma));
//        memset(ans,0,sizeof(ans));
        for(int i=0;i<K;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(ma[x][y]!=0)
                continue;
            ma[x][y]=-1;
            node t;
            t.x=x;
            t.y=y;
            q.push(t);
        }
        while(!q.empty())
        {
            node t=q.front();
            q.pop();
            if(ma[t.x][t.y]==-1){step=1;DFS(t.x,t.y);}
        }

        printf("%d\n",ans);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/liyang__abc/article/details/81328058