2018 Multi-University Training Contest 3 Problem F. Grab The Tree

原题:http://acm.hdu.edu.cn/showproblem.php?pid=6324

Problem Description

Little Q and Little T are playing a game on a tree. There are n vertices on the tree, labeled by 1,2,...,n, connected by n−1 bidirectional edges. The i-th vertex has the value of wi.
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y, he can't grab both x and y. After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.

Input

The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
In each test case, there is one integer n(1≤n≤100000) in the first line, denoting the number of vertices.
In the next line, there are n integers w1,w2,...,wn(1≤wi≤109), denoting the value of each vertex.
For the next n−1 lines, each line contains two integers u and v, denoting a bidirectional edge between vertex u and v.

Output

For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.

Sample Input

1

3

2 2 2

1 2

1 3

Sample Output

Q

分析:比赛的敲了一个dfs,因为数组开太小了还挖了两发,赛后看了一下题解,发现这题不用那么复杂,对于小Q和小T最后的结果的XOR就是所以数的XOR,因为可以先算法出XOR的前缀和sum出来,如果这个sum == 0,那么最后的结果一定是平局,因为无论小Q在树上拿了哪些数下来,这些数的XOR和小T的数的XOR加在一起的XOR一定为0,故小T的结果一定和小Q的结果一样。如果sum != 0,那么一定是小Q获胜,因为可以看作小Q从树上取了一个数出来,而这个数比其余所有数的XOR大,而最终的XOR为sum。所以只需要判断sum是否为0即可。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 200000+100;
int t, n, sum = 0;

int main(){
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		int temp;
		sum = 0;
		for(int i=1; i<=n; i++){
			scanf("%d", &temp);
			sum ^= temp;
		}
		int v, u;	
		for(int i=1; i<n; i++){
			scanf("%d%d", &v, &u);
		}
		if(sum == 0) printf("D\n");
		else printf("Q\n");
	}
}

猜你喜欢

转载自blog.csdn.net/m0_37611893/article/details/81292220