POJ 3261 Milk Patterns(后缀数组+单调栈)

POJ 3261 Milk Patterns(后缀数组+单调栈)

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 17743 Accepted: 7834
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can’t predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ KN) times. This may include overlapping patterns – 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: N and K
Lines 2..N+1: N integers, one per line, the quality of the milk on day i appears on the *i*th line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

题意

  求可重叠k次的最长重复子串。

解题思路

  先利用后缀数组得到height数组,论文里面说的是利用二分分组,对于同一组的就有公共前缀,然后找到最优解。我在这里的处理跟论文中的不一样,用了单调栈,去找到每个点的左右第一个比它小的值,根据左右可以得到一个区间,那么对于每个区间都是独立的一个组,区间的长度就是子串出现的次数,所求的子串就是该区间内最短前缀,这样求出最优就行了。单调栈的复杂度是O(n)。唯一要注意的就是这题的值可能为0。

代码

#include <cstdio>
#include <iostream>
#include <cstring>
#include <stack>
#include <algorithm>
using namespace std;
const int maxn = 2e4+50;
const int mod = 1e6+50;

int wa[mod],wb[mod],wv[mod],wt[mod],n,k;

int cmp(int *r,int a,int b,int l)
{
    return r[a]==r[b]&&r[a+l]==r[b+l];
}
void da(int r[],int sa[],int n,int m)
{
    int i,j,p,*x=wa,*y=wb,*t;
    for(i=0; i<m; i++) wt[i]=0;
    for(i=0; i<n; i++) wt[x[i]=r[i]]++;
    for(i=1; i<m; i++) wt[i]+=wt[i-1];
    for(i=n-1; i>=0; i--) sa[--wt[x[i]]]=i;
    for(j=1,p=1; p<n; j*=2,m=p)
    {
        for(p=0,i=n-j; i<n; i++) y[p++]=i;
        for(i=0; i<n; i++) if(sa[i]>=j) y[p++]=sa[i]-j;
        for(i=0; i<n; i++) wv[i]=x[y[i]];
        for(i=0; i<m; i++) wt[i]=0;
        for(i=0; i<n; i++) wt[wv[i]]++;
        for(i=1; i<m; i++) wt[i]+=wt[i-1];
        for(i=n-1; i>=0; i--) sa[--wt[wv[i]]]=y[i];
        for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1; i<n; i++)
            x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
    }
    return;
}
int sa[maxn],rankk[maxn],height[maxn];

void getheight(int *r,int *sa,int n)
{
    int i,j,k=0;
    for(i=1; i<=n; i++) rankk[sa[i]]=i;
    for(i=0; i<n; height[rankk[i++]]=k)
        for(k?k--:0,j=sa[rankk[i]-1]; r[i+k]==r[j+k]; k++);
    for(int i=n; i>=1; --i) ++sa[i],rankk[i]=rankk[i-1];
}

int arr[maxn],l[maxn],r[maxn];
stack<int> s;

int main()
{
#ifdef DEBUG
    freopen("in.txt","r",stdin);
#endif // DEBUG
    scanf("%d%d",&n,&k);
    for(int i=0; i<n; i++) scanf("%d",&arr[i]),arr[i]++;
    arr[n]=0;
    if(k==1)
    {
        printf("%d\n",n);
        return 0;
    }
    da(arr,sa,n+1,mod);
    getheight(arr,sa,n);
    height[1]=0;
    while(!s.empty()) s.pop();
    for(int i=1 ; i<=n ; i++)
    {
        while(s.size() && height[s.top()] >= height[i]) s.pop();
        if(s.empty()) l[i] = 1;
        else l[i] = s.top();
        s.push(i);
    }
    while(!s.empty()) s.pop();
    for(int i=n ; i>=1 ; i--)
    {
        while(s.size() && height[s.top()] >= height[i]) s.pop();
        if(s.empty()) r[i] = n+1;
        else r[i] = s.top();
        s.push(i);
    }
    int ans=0;
    for(int i=2; i<=n; i++) if(r[i]-l[i]>=k) ans=max(height[i],ans);
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36258516/article/details/81511772