openjudge166_The Castle

openjudge166_The Castle

时空限制    1000ms/64MB

描述

     1   2   3   4   5   6   7  
   #############################
 1 #   |   #   |   #   |   |   #
   #####---#####---#---#####---#
 2 #   #   |   #   #   #   #   #
   #---#####---#####---#####---#
 3 #   |   |   #   #   #   #   #
   #---#########---#####---#---#
 4 #   #   |   |   |   |   #   #
   #############################
(Figure 1)

#  = Wall   
|  = No wall
-  = No wall

Figure 1 shows the map of a castle.Write a program that calculates
1. how many rooms the castle has
2. how big the largest room is
The castle is divided into m * n (m<=50, n<=50) square modules. Each such module can have between zero and four walls.

输入

Your program is to read from standard input. The first line contains the number of modules in the north-south direction and the number of modules in the east-west direction. In the following lines each module is described by a number (0 <= p <= 15). This number is the sum of: 1 (= wall to the west), 2 (= wall to the north), 4 (= wall to the east), 8 (= wall to the south). Inner walls are defined twice; a wall to the south in module 1,1 is also indicated as a wall to the north in module 2,1. The castle always has at least two rooms.

输出

Your program is to write to standard output: First the number of rooms, then the area of the largest room (counted in modules).

样例输入

4
7
11 6 11 6 3 10 6
7 9 6 13 5 15 5
1 10 12 7 13 7 5
13 11 10 8 10 12 13

样例输出

5
9

代码

#include<iostream>
using namespace std;
const int N = 55;
const int dx[] = { 0,-1, 0, 1},
		  dy[] = {-1, 0, 1, 0},
		  fx[] = { 1, 2, 4, 8};
int m,n,g[N][N],tot,maxx,que[N*N][3];
bool visited[N][N];

void bfs(int x,int y){
	tot++;
	int head=0,tail=1,cnt=1;
	que[1][1]=x; que[1][2]=y;
	visited[x][y] = true;
	while (head<tail){
		head++;
		int x0=que[head][1],y0=que[head][2];
		for (int i=0; i<4; i++){
			int xx=x0+dx[i],yy=y0+dy[i];
			if (xx>=1 && xx<=m && yy>=1 && yy<=n && !visited[xx][yy] && (g[x0][y0]&fx[i])==0){
				tail++; cnt++;
				que[tail][1]=xx; que[tail][2]=yy;
				visited[xx][yy] = true;
			}
		}
	}
	if (cnt>maxx) maxx=cnt;
}

int main(){
	cin>>m>>n; 
	for (int i=1; i<=m; i++)
		for (int j=1; j<=n; j++) cin>>g[i][j];
	for (int i=1; i<=m; i++)
		for (int j=1; j<=n; j++)
			if (!visited[i][j]) bfs(i,j);
	cout<<tot<<endl<<maxx<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/WDAJSNHC/article/details/81564447
今日推荐