poj1456 Supermarket(堆,贪心)

Supermarket

Description
A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.
这里写图片描述

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input
4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10

Sample Output
80
185

Hint
The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

题意:N个商品,每个商品有利润pi和过期时间di,每天只能卖一个商品,过期商品不能再卖,求收益的最大值。

分析:建立一个小根堆储存卖出商品的集合,堆里有x个元素说明已经过了x天,如果当前商品的di等于堆的size,并且比堆顶大就替换掉堆顶,如果di比size小,直接加入堆。

代码

#include <cstdio>
#include <queue>
#include <algorithm>
#define N 10005
using namespace std;

struct arr
{
    int val,t;
}a[N];
priority_queue<arr> q;
int n;
bool operator <(const arr &x, const arr &y)
    {
        return x.val > y.val;
    }

int cmp(arr x, arr y){return x.t < y.t;}
int main()
{
    while (~scanf("%d", &n))
    {
        for (int i = 1; i <= n; i++)
            scanf("%d%d", &a[i].val, &a[i].t);
        sort(a + 1, a + n + 1, cmp);
        for (int i = 1; i <= n; i++)
        {
            int size = q.size();
            if (a[i].t <= size) 
            {
                arr now = q.top();
                if (a[i].val > now.val) q.pop(),q.push(a[i]);
            }
            else q.push(a[i]);
        }
        int ans = 0;
        while (q.size())
        {
            arr now = q.top();
            ans+=now.val;
            q.pop();
        }
        printf("%d\n", ans);
    }
}

猜你喜欢

转载自blog.csdn.net/zhanghaoxian1/article/details/81771724