2018 Multi-University Training Contest 6.oval-and-rectangle(积分+数据精度)

oval-and-rectangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 481    Accepted Submission(s): 222


 

Problem Description

Patrick Star find an oval.

The half of longer axes is on the x-axis with length a.

The half of shorter axes is on the y-axis with length b.

Patrick Star plan to choose a real number c randomly from [0,b], after that, Patrick Star will get a rectangle :

1. The four vertexes of it are on the outline of the oval.

2. The two sides of it parallel to coordinate axis.

3. One of its side is y=c.

Patrick Star want to know the expectations of the rectangle's perimeter.

 

Input

The first line contain a integer T (no morn than 10), the following is T test case, for each test case :

Each line contains contains two integer a, b (0<b<a<105). Separated by an white space.

 

Output

For each test case output one line denotes the expectations of the rectangle's perimeter .

You should keep exactly 6 decimal digits and ignore the remain decimal digits. 

It is guaranted that the 7-th decimal digit of answer wont be 0 or 9.

 

Sample Input

 

1 2 1

 

Sample Output

 

8.283185

 

Source

2018 Multi-University Training Contest 6

解题思路:先用微积分求出数学期望表达式 a * pi + 2 * b , 因为要求保留小数后 6 位,而 double 型数据会自动进位,因此做一下进位处理。

#include<bits/stdc++.h>
using namespace std;
#define pi acos(-1.0)
int main()
{
    double n,m;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf",&n,&m);
        double i=n*pi+2*m-0.0000004;
        printf("%.6f\n",i);

    }
}

猜你喜欢

转载自blog.csdn.net/XxxxxM1/article/details/81532397
今日推荐