[C/C++] 1027 Colors in Mars (20)(20 分)

1027 Colors in Mars (20)(20 分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.

Sample Input

15 43 71

Sample Output

#123456

感觉没错的,就是只有16分

#include<stdio.h> 
int main()
{   
    int decimal[3];
    scanf("%d%d%d",&decimal[0],&decimal[1],&decimal[2]);

    printf("#");
    for(int i=0;i<3;i++){
    char mars[2]={0};
        int num=0;
        do{
            mars[num++] = decimal[i] % 13;
            decimal[i] /= 13;
        }while(decimal[i]!=0);
        for(int i=1;i>=0;i--){
            if(mars[i]==10) printf("A");
            if(mars[i]==11) printf("B");
            if(mars[i]==12) printf("C");
            else printf("%d",mars[i]);
        }   
    }

    return 0;
 } 

猜你喜欢

转载自blog.csdn.net/dulongxiang/article/details/81635481