[ PAT-A ] 1028 List Sorting (C++)

题目描述

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input
Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90


解题思路

题目大意
按三种情况排序,分别是按ID编号,按姓名,按成绩
思路
一道非常简单的排序题目,可以自己写一个关于排序的算法,比如归并,快速排序等,本题采用STL库中algorithm已有的sort算法进行排序


代码设计
//AC代码
//zhicheng
#include<cstdio>
#include<iostream>
#include<vector>
#include<algorithm>
#include<cstring>
using namespace std;
//zhicheng
//August 11,2018
typedef struct{int numb;char name[9];int sco;}D;
vector<D>a;
bool comp1(D a,D b){return a.numb<b.numb;}
bool comp2(D a,D b){if(strcmp(a.name,b.name)==0)return a.numb<b.numb;else return strcmp(a.name,b.name)<0;}
bool comp3(D a,D b){if(a.sco!=b.sco)return a.sco<b.sco;else return a.numb<b.numb;}
int main()
{
    // freopen("1.txt","r",stdin);
    int n,c;
    while(~scanf("%d %d",&n,&c))
    {
        a.clear();
        D tmp;
        for(int i=0;i<n;i++){scanf("%d %s %d",&tmp.numb,tmp.name,&tmp.sco);a.push_back(tmp);}
        if(c==1)sort(a.begin(),a.end(),comp1);
        else if(c==2)sort(a.begin(),a.end(),comp2);
        else if(c==3)sort(a.begin(),a.end(),comp3);
        for(int i=0;i<n;i++) printf("%06d %s %d\n",a[i].numb,a[i].name,a[i].sco);
    }
    return 0;
}


有关PAT (Basic Level) 的更多内容可以关注 ——> PAT-B题解


有关PAT (Advanced Level) 的更多内容可以关注 ——> PAT-A题解

铺子日常更新,如有错误请指正
传送门:代码链接 PTA题目链接 PAT-A题解

猜你喜欢

转载自blog.csdn.net/S_zhicheng27/article/details/81585550
今日推荐