POJ 2752 Seek the Name, Seek the Fame(next数组运用)

Seek the Name, Seek the Fame
Time Limit: 2000MS        Memory Limit: 65536K
Total Submissions: 24000        Accepted: 12525
Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 
Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 
Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.
Sample Input

ababcababababcabab
aaaaa
Sample Output

2 4 9 18
1 2 3 4 5
题意:给出一个字符串str,求出str中存在多少子串,既是str的前缀,又是str的后缀,从小到大输出长度(开一个数组倒序输出即可)

#include<iostream>
#include<string.h>
using namespace std;
char s[411111];
int pp,nex[411111],nexx[411111];
void getnext()
{
    int i=0,k=-1;
    nex[0]=-1;
    while(i<pp)
    {
        if(k==-1||s[i]==s[k])
            nex[++i]=++k;//,cout<<nex[i];
        else
            k=nex[k];
    }
}
int main()
{
    int j;
    while(~scanf("%s",s))
    {
        j=0;
        pp=strlen(s);
        getnext();
        for(int i=pp;nex[i]!=-1;i=nex[i])
            nexx[j++]=i;
        for(int i=j-1;i>=0;i--)
            i?printf("%d ",nexx[i]):printf("%d\n",nexx[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42060896/article/details/81806047
今日推荐