@2018中国大学生程序设计竞赛 - 网络选拔赛:1003 Dream (题意理解)

版权声明:岂曰无衣,与子同袍 https://blog.csdn.net/sizaif/article/details/82078483

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6440

Dream

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 877    Accepted Submission(s): 108
Special Judge

 

Problem Description

Freshmen frequently make an error in computing the power of a sum of real numbers, which usually origins from an incorrect equation (m+n)p=mp+np, where m,n,p are real numbers. Let's call it ``Beginner's Dream''.

For instance, (1+4)2=52=25, but 12+42=17≠25. Moreover, 9+16−−−−−√=25−−√=5, which does not equal 3+4=7. 

Fortunately, in some cases when p is a prime, the identity

(m+n)p=mp+np


holds true for every pair of non-negative integers m,n which are less than p, with appropriate definitions of addition and multiplication.

You are required to redefine the rules of addition and multiplication so as to make the beginner's dream realized.

Specifically, you need to create your custom addition and multiplication, so that when making calculation with your rules the equation (m+n)p=mp+np is a valid identity for all non-negative integers m,n less than p. Power is defined as

ap={1,ap−1⋅a,p=0p>0



Obviously there exists an extremely simple solution that makes all operation just produce zero. So an extra constraint should be satisfied that there exists an integer q(0<q<p) to make the set {qk|0<k<p,k∈Z} equal to {k|0<k<p,k∈Z}. What's more, the set of non-negative integers less than p ought to be closed under the operation of your definitions.

Hint


Hint for sample input and output:
From the table we get 0+1=1, and thus (0+1)2=12=1⋅1=1. On the other hand, 02=0⋅0=0, 12=1⋅1=1, 02+12=0+1=1.
They are the same.

 

Input

The first line of the input contains an positive integer T(T≤30) indicating the number of test cases.

For every case, there is only one line contains an integer p(p<210), described in the problem description above. p is guranteed to be a prime.

 

Output

For each test case, you should print 2p lines of p integers.

The j-th(1≤j≤p) integer of i-th(1≤i≤p) line denotes the value of (i−1)+(j−1). The j-th(1≤j≤p) integer of (p+i)-th(1≤i≤p) line denotes the value of (i−1)⋅(j−1).

 

Sample Inpu

1 2

Sample Output

0 1

1 0

0 0

0 1

 

[题意] :

非常nice 的题意,    读不懂,,读不懂

构造 p*p的 矩阵加法  和 p*p的矩阵乘法

定义 加法  m+n  和 乘法 m*n  使得 (m+n)^p = m^p +n^p

[思路]

根据费马小定理 :  (a)^p \equiv a

所以 定义 

 (m+n) := (m+n) mod P

(m*n) := (m*n)mod P

[代码]

#include <bits/stdc++.h>
#include <stdio.h>
#define rep(i,a,n) for(int i=a;i<=n;i++)

using namespace std;

int main(int argc, char const *argv[])
{
	
	int T,p;
	scanf("%d",&T);

	// (x+y) := (x+y)mod p
	// (x*y) := (x*y)mod p
	while(T--)
	{
		scanf("%d",&p);
		rep(i,1,p){
			rep(j,1,p){
				printf("%d%c",(i+j-2)%p,j==p?'\n':' ');
			}
		}
		rep(i,1,p){
			rep(j,1,p){
				printf("%d%c",((i-1)*(j-1)%p),j==p?'\n':' ');
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/sizaif/article/details/82078483
今日推荐