POJ 2395 Out of Hay 最小生成树

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M.

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43

Hint

OUTPUT DETAILS:

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

题意:

小女孩想从1到达N, 求小女孩到达目的地边的最小路径的最大边。

一开始最先想到的是迪杰斯特拉算法, 飞速写了个然后光速去世。 然后搜了下, 发现原来是最小生成树。 。。感觉自己好蠢。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=10005;
const int max1=2005;
struct edge
{
    int s,e;
    int sp;
};
edge e[maxn];
int n,m;
int a[max1];
int compare (edge a,edge b)
{
    return a.sp<b.sp;
}
void init ()
{
    for (int i=1;i<=n;i++)
        a[i]=i;
}
int finds (int x)
{
    if(a[x]==x)
        return x;
    return a[x]=finds(a[x]);
}
bool unit(int x,int y)
{
    int temp1=finds(x);
    int temp2=finds(y);
    if(temp1!=temp2)
    {
        a[temp1]=temp2;
        return true;
    }
    return false;
}
void kual ()
{
    sort (e,e+m,compare);
    int num=n,maxx=-1;
    for (int i=0;i<m&&num>1;i++)
    {
        if(unit(e[i].s,e[i].e))
        {
            num--;
            maxx=max(maxx,e[i].sp);
        }
    }
    printf("%d\n",maxx);
}
int main()
{
    while (scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        for (int i=0;i<m;i++)
            scanf("%d%d%d",&e[i].s,&e[i].e,&e[i].sp);
        kual();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/81916337