POJ2395 Out of Hay【Kruskal算法+并查集】

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 19362   Accepted: 7592

Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.  

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.  

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

Input

* Line 1: Two space-separated integers, N and M.  

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

Output

* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43

Hint

OUTPUT DETAILS:  

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

Source



问题链接POJ2395 Out of Hay

问题描述:(略)

问题分析

  这是一个最小生成树的为问题,解决的算法有Kruskal(克鲁斯卡尔)算法和Prim(普里姆) 算法。

  这个题要算的是,最小生成树中的最大的边。

程序说明

  本程序使用Kruskal算法实现。有关最小生成树的问题,使用克鲁斯卡尔算法更具有优势,只需要对所有的边进行排序后处理一遍即可。程序中使用了并查集,用来判定加入一条边后会不会产生循环。程序中,图采用边列表的方式存储,排序一下就好了。

  计算最小生成树中的最大的边,代码需要做相应的修改。


AC的C++语言程序如下:

/* POJ2395 Out of Hay */

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 2000;
const int M = 10000;

int f[N + 1];

void UFInit(int n)
{
    for(int i = 1; i <=n; i++)
        f[i] = i;
}

int Find(int a) {
    return a == f[a] ? a : f[a] = Find(f[a]);
}

bool Union(int a, int b)
{
    a = Find(a);
    b = Find(b);
    if (a != b) {
        f[a] = b;
        return true;
    } else
        return false;
}

struct Edge {
    int u, v, w;
} edges[M];

bool cmp(Edge a, Edge b)
{
    return a.w < b.w;
}

int main()
{
    int n, m;
    while(~scanf("%d%d", &n, &m)) {
        UFInit(n);

        for(int i = 0; i < m; i++)
            scanf("%d%d%d", &edges[i].u, &edges[i].v, &edges[i].w);

        // Kruscal算法
       int maxw = 0, cnt = 0;
       sort(edges, edges + m, cmp);
       for(int i = 0; i < m; i++) {
           if(Union(edges[i].u, edges[i].v)) {
               if(edges[i].w > maxw)
                   maxw = edges[i].w;
               if(++cnt == n - 1)
                   break;
           }
       }

       printf("%d\n", maxw);
    }

    return 0;
}








猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80961901