1052 Linked List Sorting(25 分)(C++)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Nextpointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<10​5​​) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10​5​​,10​5​​], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题目大意:按链表节点的value值排列链表。

注意:有些节点不一定在链表中,所以要先进行遍历。

#include<iostream>
#include<vector>
#include<algorithm>
#include<cstdio>
#include<string>
using namespace std;
typedef struct {
    int add;
    int num;
    int addnext;
}node;
int cmp(node n1,node n2){
    return n1.num<n2.num;
}
int main(){
    int n,k;
    scanf("%d %d",&n,&k);
	std::vector<node> all;
    all.resize(100000);
    for(int i=0;i<n;++i){
        int addr;
        scanf("%d",&addr);
        scanf("%d %d",&all[addr].num,&all[addr].addnext);
    }
    int sum=0;
    std::vector<node> v;
    while(k!=-1){
        v.push_back(all[k]);
        v[sum++].add=k;
	k=all[k].addnext;
    }
    sort(v.begin(), v.end(),cmp);
    printf("%d ",sum);
    for(int i=0;i<v.size();++i){
        printf("%05d\n%05d %d ",v[i].add,v[i].add,v[i].num);
        }
    printf("-1\n");
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/82146249