PAT甲级 1052 Linked List Sorting (25 分)排序

1052 Linked List Sorting (25 分)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<10​5​​) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10​5​​,10​5​​], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题目大意:给出一个链表,将链表排序,然后把链表上的结点按照data值的从小到大顺序输出
分析:建立结构体数组,按照从首地址开始的顺序(直到-1)遍历一遍整个链表,将在链表中的结点的flag标记为true,并且统计cnt(有效结点的个数,因为有的结点根本不在链表中!!!),将有效结点加入到list. 然后将list链表进行排序~

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<vector>
using namespace std;

struct node{
	int address,key,next;
	bool flag;//标明是否在链表中 
}arr[100001];

int cmp(node a,node b){
	return a.key < b.key;
}

int main(){
	int n,head,address,key,next;
	scanf("%d%d",&n,&head);
	for(int i=0;i<n;i++){
		scanf("%d%d%d",&address,&key,&next);
		arr[address] = node{address,key,next,false};
	}
		
	int cnt = 0;
	vector<node> list;
	for(int i = head;i != -1;i = arr[i].next)
	{
		arr[i].flag = true;
		cnt++;
		list.push_back(arr[i]);
	}
	if(cnt == 0)//记得防止链表为空,否则会产生下面的list[0]段错误 
	{
		printf("0 -1");
		return 0;
	}
	
	sort(list.begin(),list.end(),cmp);
	printf("%d %05d\n",cnt,list[0].address);
	for(int i=0;i<cnt-1;i++)
		printf("%05d %d %05d\n",list[i].address,list[i].key,list[i+1].address);
	printf("%05d %d -1",list[cnt-1].address,list[cnt-1].key);
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/82663616