HDU 1018. 求n的阶乘的位数

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
 
  
2 10 20
 
Sample Output
 
  
7 19

很明显,这道题直接算的话会超时。所以要寻求一些数学规律。

1*2*3*4*5*......的位数等于log10(1)+log10(2)+log10(3)+log10(4)+log10(5)+1

所以代码就很容易写出来了

#include<iostream>
#include<stack>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<map>
using namespace std;

int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        int n;double ans=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            ans+=log10(i);
        printf("%d\n",(int)(ans)+1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wzazzy/article/details/80938201
今日推荐