Let's Chat ZOJ - 3961 (离散化)

ACM (ACMers' Chatting Messenger) is a famous instant messaging software developed by Marjar Technology Company. To attract more users, Edward, the boss of Marjar Company, has recently added a new feature to the software. The new feature can be described as follows:

If two users, A and B, have been sending messages to each other on the last mconsecutive days, the "friendship point" between them will be increased by 1 point.

More formally, if user A sent messages to user B on each day between the (i - m + 1)-th day and the i-th day (both inclusive), and user B also sent messages to user A on each day between the (i - m + 1)-th day and the i-th day (also both inclusive), the "friendship point" between A and B will be increased by 1 at the end of the i-th day.

Given the chatting logs of two users A and B during n consecutive days, what's the number of the friendship points between them at the end of the n-th day (given that the initial friendship point between them is 0)?

Input

There are multiple test cases. The first line of input contains an integer T (1 ≤ T≤ 10), indicating the number of test cases. For each test case:

The first line contains 4 integers n (1 ≤ n ≤ 109), m (1 ≤ m ≤ n), x and y (1 ≤ x, y ≤ 100). The meanings of n and m are described above, while x indicates the number of chatting logs about the messages sent by A to B, and y indicates the number of chatting logs about the messages sent by B to A.

For the following x lines, the i-th line contains 2 integers la, i and ra, i (1 ≤ la,i ≤ ra, i ≤ n), indicating that A sent messages to B on each day between the la, i-th day and the ra, i-th day (both inclusive).

For the following y lines, the i-th line contains 2 integers lb, i and rb, i (1 ≤ lb,i ≤ rb, i ≤ n), indicating that B sent messages to A on each day between the lb, i-th day and the rb, i-th day (both inclusive).

It is guaranteed that for all 1 ≤ i < x, ra, i + 1 < la, i + 1 and for all 1 ≤ i < y, rb, i + 1 < lb, i + 1.

Output

For each test case, output one line containing one integer, indicating the number of friendship points between A and B at the end of the n-th day.

Sample Input

2
10 3 3 2
1 3
5 8
10 10
1 8
10 10
5 3 1 1
1 2
4 5

Sample Output

3
0

Hint

For the first test case, user A and user B send messages to each other on the 1st, 2nd, 3rd, 5th, 6th, 7th, 8th and 10th day. As m = 3, the friendship points between them will be increased by 1 at the end of the 3rd, 7th and 8th day. So the answer is 3.

题意:两人间连续相互发消息超过某个天数之后每多聊一天就增加一点亲密度,问两人之间最终的亲密度是多少。

思路:向对方发消息的天数的数据加一,再统计出哪些天数的数据为2即可。考虑到数据较大,需要离散化,以及由于离散化,一些原本不相邻的点变成了相邻点,所以需要插点。

AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<cstring>
using namespace std;
int main()
{
	int la[1005],ra[1005];
	int lb[1005],rb[1005];
	int idal[1005],idbl[1005];
	int idar[1005],idbr[1005];
	int id[1005];
	int t;
	int date[1005];
	int num[1005];
	scanf("%d",&t);
	while(t--)
	{
		int n,m,x,y;
		memset(id,0,sizeof(id));
		memset(date,0,sizeof(date));
		int cnt=0;
		scanf("%d%d%d%d",&n,&m,&x,&y);
		for(int i=0;i<x;i++)
		{
			scanf("%d%d",&la[i],&ra[i]);
			num[cnt++]=la[i];
			num[cnt++]=ra[i];
		}
		for(int i=0;i<y;i++)
		{
			scanf("%d%d",&lb[i],&rb[i]);
			num[cnt++]=lb[i];
			num[cnt++]=rb[i];
		}
		sort(num,num+cnt);
		cnt=unique(num,num+cnt)-num;
		int sz=cnt;
		for(int i=1;i<sz;i++)
		{
			if(num[i]-num[i-1]>1) num[cnt++]=num[i-1]+1;
		}
		sort(num,num+cnt);
		for(int i=0;i<x;i++)
		{
			idal[i]=lower_bound(num,num+cnt,la[i])-num+1;
			id[idal[i]]=la[i];
			idar[i]=lower_bound(num,num+cnt,ra[i])-num+1;
			id[idar[i]]=ra[i];
		}
		for(int i=0;i<y;i++)
		{
			idbl[i]=lower_bound(num,num+cnt,lb[i])-num+1;
			id[idbl[i]]=lb[i];
			idbr[i]=lower_bound(num,num+cnt,rb[i])-num+1;
			id[idbr[i]]=rb[i];
		}
		for(int i=0;i<x;i++)
		{
			for(int j=idal[i];j<=idar[i];j++)
			{
				++date[j];
			}
		}
		for(int i=0;i<y;i++)
		{
			for(int j=idbl[i];j<=idbr[i];j++)
			{
				++date[j];
			}
		}
		int l=-1;
		int ans=0;
		for(int i=1;i<=cnt;i++)
		{
			if(date[i]==2&&l==-1) l=i;
			else if(l!=-1&&date[i]!=2)
			{
				//cout<<id[i-1]<<' '<<id[l]<<endl;
				if(id[i-1]-id[l]+1>=m)
				ans+=(id[i-1]-id[l]+2-m);
				l=-1;
			}
		}
		printf("%d\n",ans);
	}
}

猜你喜欢

转载自blog.csdn.net/baiyifeifei/article/details/82261488
ZOJ