浙江省第十四次ACM程序竞赛 Let's Chat(D题)(区间)

浙江省第十四次ACM程序竞赛 Let's ChatD题)

ACM (ACMers'Chatting Messenger) is a famous instant messaging software developed by MarjarTechnology Company. To attract more users, Edward, the boss of Marjar Company,has recently added a new feature to the software. The new feature can bedescribed as follows:

If two users, Aand B, have been sending messages to each other on thelast mconsecutive days, the "friendship point"between them will be increased by 1 point.

More formally, ifuser A sent messages to user B on each day between the (i - m +1)-th day and the i-th day (both inclusive), and user B also sentmessages to user A on each day between the (i - m +1)-th day and the i-th day (also both inclusive), the"friendship point" between A and B will be increased by 1 at the endof the i-th day.

Given the chattinglogs of two users A and B during n consecutive days, what'sthe number of the friendship points between them at the end of the n-thday (given that the initial friendship point between them is 0)?

Input

There are multipletest cases. The first line of input contains an integer T (1≤ T≤ 10), indicating the number of test cases. For each test case:

The first linecontains 4 integers n (1 ≤ n ≤ 109), m (1≤ m ≤ n), x and y (1≤ xy ≤ 100). The meanings of n and m aredescribed above, while x indicates the number of chatting logsabout the messages sent by A to B, and y indicates the numberof chatting logs about the messages sent by B to A.

For thefollowing x lines, the i-th line contains 2integers lai and rai (1≤ la,i ≤ rai ≤ n),indicating that A sent messages to B on each day between the lai-thday and the rai-th day (bothinclusive).

For thefollowing y lines, the i-th line contains 2integers lbi and rbi (1≤ lb,i ≤ rbi ≤ n),indicating that B sent messages to A on each day between the lbi-thday and the rbi-th day (bothinclusive).

It is guaranteedthat for all 1 ≤ i < xrai +1 < lai + 1 andfor all 1 ≤ i < yrbi +1 < lbi + 1.

<h4< dd=""></h4<>

Output

For each testcase, output one line containing one integer, indicating the number offriendship points between A and B at the end of the n-th day.

<h4< dd=""></h4<>

Sample Input

2

10 3 3 2

1 3

5 8

10 10

1 8

10 10

5 3 1 1

1 2

4 5

<h4< dd=""></h4<>

Sample Output

3

0

<h4< dd=""></h4<>

Hint

For the first testcase, user A and user B send messages to each other on the 1st, 2nd, 3rd, 5th,6th, 7th, 8th and 10th day. As m = 3, the friendship pointsbetween them will be increased by 1 at the end of the 3rd, 7th and 8th day. Sothe answer is 3.

求区间的交集!!!


我的代码:

#include <iostream>
#include <cstdio>
#include <map>

using namespace std;

map<int,int> A,B;
int startA[105],startB[105];
int n,m,x,y;
int a,b;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int point = 0;
        scanf("%d%d%d%d",&n,&m,&x,&y);
        int k = 0;
        for(int i = 0 ; i < x ;i++)
        {
            scanf("%d%d",&a,&b);
            A[a] = b;
            startA[k++] = a;
        }
        k = 0;
        for(int i = 0 ; i < y ; i++)
        {
            scanf("%d%d",&a,&b);
            B[a] = b;
            startB[k++]= a;
        }
        for(int i = 0 ; i < x ;i++)//把A的情况都遍历一遍
        {
            int sa = startA[i];
            int ea = A[startA[i]];
            if(sa + m-1 <= ea)//如果A的这一段符合条件的话
            {
                for(int j = 0 ; j < y ; j++)
                {
                    int sb = startB[j];
                    int eb = B[startB[j]];
                    int l = sa,r = ea;
                    if(startB[j]+m-1<= B[startB[j]])
                    {
                       l = max(sa,sb);
                       r = min(ea,eb);
                       if(r -l+1-m+1>0)
                             point +=(r - l+1-m+1);
                    }
                }

            }
        }
        printf("%d\n",point);
    }

    return 0;
}

别人博客简洁的代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=100+10;
struct node{
	int l,r;
}X[maxn],Y[maxn];
int n,m,x,y;

int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d%d%d",&n,&m,&x,&y);
		for(int i=1;i<=x;i++)
		scanf("%d%d",&X[i].l,&X[i].r);
		for(int i=1;i<=y;i++)
		scanf("%d%d",&Y[i].l,&Y[i].r);
		
		int tol=0;
		for(int i=1;i<=x;i++)
		{
			if(X[i].r-X[i].l+1 < m)continue;  //小于m就不用进行下面操作了 
			
			for(int j=1;j<=y;j++)
			{
				if(Y[j].r-Y[j].l+1 < m)continue;
				
				int L,R;
				R=min(X[i].r,Y[j].r);
				L=max(X[i].l,Y[j].l);
				int len=R-L+1;
				if(len>=m){
					tol+=(len-m+1);
				}
			}
		}
		printf("%d\n",tol);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Xuedan_blog/article/details/80159902