DNA Sorting OpenJ_Bailian - 1007

DNA Sorting OpenJ_Bailian - 1007

One measure of unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequenceDAABEC”, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequenceZWQM” has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness'', frommost sorted” to least sorted''. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from
most sorted” to “least sorted”. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

#include <stdio.h>
#include <stdlib.h>
#include<string.h>
int main()
{
    char s[201][201];
    int n,len,i,j,k,flag,a[1000]= {0};
    scanf("%d %d",&len,&n);
    for(i=0; i<n; i++)
    {
        for(j=0; j<len; j++)
        {
            scanf(" %c",&s[i][j]);//遵循字符数组输入格式,前面要留有空格。
        }
    }
    i=0;初始时行为零
    while(i<n)
    {
        for(j=0; j<len; j++)
        {
            for(k=j+1; k<len; k++)
            {
                if(s[i][j]>s[i][k])
                    a[i]++;//计算每一行的度量,满足条件加一,行量度用数组记录
            }
        }
        i++;//换行
    }
    int l=n;
    while(l--)
    {
        int min=100000;//此处min的初始值一定要足够大,不然每行的量度都大于min找不出最小的量度,flag无值,min不够大时会一直runtime error.
        for(i=0; i<n; i++)
        {
            if(a[i]<min&&a[i]!=-1)
            {
                min=a[i];
                flag=i;
            }
        }
        a[flag]=-1;
        for(j=0; j<len; j++)
            printf("%c",s[flag][j]);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41938269/article/details/82154009