HDU2010 水仙花数

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 65536/32768 K (Java/Others)

Description
春天是鲜花的季节,水仙花就是其中最迷人的代表,数学上有个水仙花数,他是这样定义的:
“水仙花数”是指一个三位数,它的各位数字的立方和等于其本身,比如:153=1^3+5^3+3^3。
现在要求输出所有在m和n范围内的水仙花数。
Input
输入数据有多组,每组占一行,包括两个整数m和n(100<=m<=n<=999)。
Output
对于每个测试实例,要求输出所有在给定范围内的水仙花数,就是说,输出的水仙花数必须大于等于m,并且小于等于n,如果有多个,则要求从小到大排列在一行内输出,之间用一个空格隔开;
如果给定的范围内不存在水仙花数,则输出no;
每个测试实例的输出占一行。
Sample Input

100 120
300 380

Sample Output

no
370 371

Hint
JGShining
Source
  C语言程序设计练习(二)  
Related problem
2005 2007 2012 2001 2000

可以考虑写个bool函数,判断一个数是否为水仙花数,再到主函数中调用该函数。主函数再在给出的范围中遍历,判断。

有个问题是输出格式,末尾不能出现空格号。

代码如下:

#include <iostream>
using namespace std;
bool isFlower(int a)
{
int b,temp=a,sum=0;
for(int i=0;i<3;i++)
{
    b=a%10;
    sum+=b*b*b;
    a/=10;
}
if(sum==temp)
    return true;
return false;
}
int main ()
{
int m,n;
while(cin>>m>>n)
{
int count=0;
for(int i=m;i<=n;i++){
    if(isFlower(i))
    {    if(count !=0)
             cout<<" ";
        cout<<i;
        count++;
    }       
}
if(count==0)
    cout<<"no";
 cout<<endl;
}
}

猜你喜欢

转载自blog.csdn.net/qq_41627235/article/details/82789658