UVA-400:Unix ls

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/wingrez/article/details/82774795

UVA-400:Unix ls

来源:UVA

标签:

参考资料:《算法竞赛入门经典》P127

相似题目:

题目

The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the ls function. Your program will eventually read input from a pipe (although for now your program will read from the input file). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into © columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows ® as possible with rows being filled to capacity from left to right.

输入

The input file will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer (1 ≤ N ≤ 100). There will then be N lines each containing one left-justified filename and the entire line’s contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to z, A to Z, and 0 to 9) and from the following set {._-} (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty. Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input file.

输出

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenames R + 1 to 2R listed down column 2; etc.

输入样例

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben

输出样例

在这里插入图片描述

参考代码

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;

const int maxcol=60;
const int maxn=100+5;
string filenames[maxn];

//输出字符串s,长度不足len时补字符extra
void print(const string& s, int len, char extra){
    cout<<s;
    for(int i=0;i<len-s.length();i++){
        cout<<extra;
    }
}

int main(){
    int n;
    while(cin>>n){
        int M=0;
        for(int i=0;i<n;i++){
            cin>>filenames[i];
            M=max(M,(int)filenames[i].length());
        }
        //计算列数cols和行数rows
        int cols=(maxcol-M)/(M+2)+1,
            rows=(n-1)/cols+1;
        print("",60,'-');
        cout<<"\n";
        sort(filenames, filenames+n);//排序
        for(int r=0;r<rows;r++){
            for(int c=0;c<cols;c++){
                int idx=c*rows+r;
                if(idx<n) print(filenames[idx],c==cols-1?M:M+2,' ');
            }
            cout<<"\n";
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wingrez/article/details/82774795
ls
今日推荐