POJ1589 ZOJ1324 UVA400 UVALive5484 Unix ls【排序+文本处理】

Unix ls

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 2876   Accepted: 967

Description

The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the ls function. 
Your program will eventually read input from a pipe (although for now your program will read from the input). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to right. 
 

Input

The input will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer (1 <= N <= 100). There will then be N lines each containing one left-justified filename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to z, A to Z, and 0 to 9) and from the following set { ._- } (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty. 

Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input. 

Output

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenames R+1 to 2R listed down column 2; etc.

Sample Input

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben

Sample Output

------------------------------------------------------------
12345678.123         size-1
2short4me            size2
mid_size_name        size3
much_longer_name     tiny
shorter              very_long_file_name
------------------------------------------------------------
Alfalfa        Cotton         Joe            Porky
Buckwheat      Darla          Mrs_Crabapple  Stimey
Butch          Froggy         P.D.           Weaser
------------------------------------------------------------
Alice       Chris       Jan         Marsha      Ruben
Bobby       Cindy       Jody        Mike        Shirley
Buffy       Danny       Keith       Mr._French  Sissy
Carol       Greg        Lori        Peter

Source

South Central USA 1995

扫描二维码关注公众号,回复: 3079730 查看本文章

Regionals 1995 >> North America - South Central USA

问题链接POJ1589 ZOJ1324 UVA400 UVALive5484 Unix ls

问题描述:(略)

问题分析

  在文本界面时代,一个目录下的目录和文件需要显示,并且按照一定的格式进行显示。这个题就是解决这样的问题的。

  需要显示的文件名需要排序一下。

  这个题的关键是计算总共的行数和列数,本来需要考虑能否整除的问题,如果用条件判断来做逻辑清晰,但是描述繁琐,找出一个计算公式来并且用一个表达式来描述计算就简洁了。

程序说明

  这个程序在ZOJ1324中出现PE,只能说ZOJ的测试数据与众不同,也许是考虑了特殊的情况?

参考链接:(略)

题记:用表达式描述一个计算是最简洁的方式。

AC的C++语言程序(ZOJ1324中PE)如下:

/* POJ1589 ZOJ1324 UVA400 UVALive5484 Unix ls */

#include <iostream>
#include <algorithm>

using namespace std;

const int COL = 60;
const int N = 100;
string fn[N];

// 输出字符串s,补足空格使之长度为len
void print(const string& s, int len, char extra)
{
    cout << s;
    len -= s.length();
    while(len--)
        cout << extra;
}

int main()
{
    int n;
    while(cin >> n) {
        int maxlen = 0;
        for(int i = 0; i < n; i++) {
            cin >> fn[i];
            maxlen = max(maxlen, (int)fn[i].length());
        }

        // 计算行数rows和列数cols
        int cols = (COL - maxlen) / (maxlen + 2) + 1;
        int rows = (n - 1) / cols + 1;

        // 输出结果:先按字典顺序排序
        sort(fn, fn + n);
        print("", COL, '-');
        cout << endl;
        for(int i = 0; i < rows; i++) {
            for(int j = 0; j < cols; j++) {
                int idx = j * rows + i;
                if(idx < n)
                    print(fn[idx], j == cols - 1 ? maxlen : maxlen + 2, ' ');
                else
                    break;
            }
            cout << endl;
        }
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/82283828