POJ1598 ZOJ1315 HDU1606 UVA409 UVALive5493 Excuses, Excuses!【文本】

Excuses, Excuses!
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4701 Accepted: 1602

Description

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

Input

Input to your program will consist of multiple sets of data. Line 1 of each set will contain exactly two integers. The first number (1 <= K <= 20) defines the number of keywords to be used in the search. The second number (1 <= E <= 20) defines the number of excuses in the set to be searched. Lines 2 through K+1 each contain exactly one keyword. Lines K+2 through K+1+E each contain exactly one excuse. All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L (1 <= L <= 20) and will occupy columns 1 through L in the input line. All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [".,!?] not including the square brackets and will not exceed 70 characters in length. Excuses will contain at least 1 non-space character.

Output

For each input set, you are to print the worst excuse(s) from the list. The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords. If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence. A keyword "occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.

For each set of input, you are to print a single line with the number of the set immediately after the string "Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order. After each set of output, you should print a blank line.

Sample Input

5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary... AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890.....,,,,,0987654321?????!!!!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework ... note outdated keywords?

Sample Output

Excuse Set #1
Can you believe my dog died after eating my canary... AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!

Source

South Central USA 1996

Regionals 1996 >> North America - South Central USA

问题链接POJ1598 ZOJ1315 HDU1606 UVA409 UVALive5493 Excuses, Excuses!
问题简述:(略)
问题分析
    文本处理题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ1598 ZOJ1315 HDU1606 UVA409 UVALive5493 Excuses, Excuses! */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cctype>

using namespace std;

const int K = 20;
const int E = 20;
const int L = 20;
const int L2 = 70;
char key[K][L + 1], excuse[E][L2 + 1], t[L2 + 1];
int sum[K];

int main()
{
    int k, e, caseno = 0;
    while(~scanf("%d%d", &k, &e)) {
        for(int i = 0; i < k; i++)
            scanf("%s", key[i]);
        getchar();      // 吃掉最后的换行,为读入行做准备

        memset(sum, 0, sizeof(sum));
        int maxsum = 0;
        for(int i = 0; i < e; i++) {
            gets(excuse[i]);
            for(int j = 0; excuse[i][j]; j ++) {
                int cnt = 0;
                while(isalpha(excuse[i][j]))
                    t[cnt++] = tolower(excuse[i][j++]);
                t[cnt] = '\0';
                if(cnt) {
                    for(int l = 0; l < k; l++)
                        if(strcmp(t, key[l]) == 0) {
                            sum[i]++;
                            break;
                        }
                }
            }
            maxsum = max(maxsum, sum[i]);
        }
        printf("Excuse Set #%d\n", ++caseno);
        for(int i = 0; i < e; i++)
            if(sum[i] == maxsum)
                printf("%s\n", excuse[i]);
        printf("\n");
    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/tigerisland45/p/10386727.html