Wormholes POJ - 3259 SPFA 最短路

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

第二发spfa  -。-至于为啥要用邻接表主要是这个有重边 无向的path可能会被有向的wormhole覆盖 又不是求最短路所以每条边必须保存

所以邻接表是最好的选择 因为直接上一波vector就好了嘛

#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
#include<vector>
#define clr(a,b) memset(a,b,sizeof(a));
#define inf 0x3f3f3f3f
using namespace std;
int f,n,m,w,visit[505],index[505],dis[505];
struct node
{
	int to;
	int power;
};
vector <node> ma[505];//使用邻接表来存数据 ma[i][j].to i是出发点 j是边的编号 to是到达点 上一次直接用简单粗暴的结构体二维数组存的图 贼粗暴 

int spfa()
{
	queue<int> q;
	q.push(1);//始点是一的单源最短路 
	dis[1]=0;
	visit[1]=1;
	index[1]=1;
	int in=0;
	while(!q.empty())
	{
		in=q.front();
		q.pop();
		visit[in]=0;
		if(index[in]>n)
		{
			return 1;
		}
		for(int i=0;i<ma[in].size();i++)
		{
			int to=ma[in][i].to;
			if(dis[to]>dis[in]+ma[in][i].power)
			{
		        dis[to]=dis[in]+ma[in][i].power;
				if(!visit[to])
				{
					visit[to]=1;
					q.push(to);
					index[to]++;						
				}
			}
		}
	}
	return 0;
}

int main()
{
	ios::sync_with_stdio(false);
	cin>>f;
	while(f--)
	{
		cin>>n>>m>>w;
		for(int i=0;i<=504;i++)
		ma[i].clear();
		clr(visit,0)
		clr(index,0)
		clr(dis,inf)
		for(int i=1;i<=m;i++)
		{
			int s,e,p;
			node g;
			cin>>s>>e>>p;
			g.to=e;
			g.power=p;
			ma[s].push_back(g);
			g.to=s;
			ma[e].push_back(g);
			
		}
		for(int i=1;i<=w;i++)
		{
			int s,e,p;
			node g;
			cin>>s>>e>>p;
			g.to=e;
			g.power=-p;
			ma[s].push_back(g);
		}
		if(spfa()) cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
	}
	return 0; 
}

猜你喜欢

转载自blog.csdn.net/weixin_41544329/article/details/82634768