POJ 3259 Wormholes(spfa判负权)

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

解题思路:

每个节点进入队列的次数至多为n-1次(一共n个节点),若进入大于等于n次了,则说明图中存在负权回路,此时正好满足题目中时光倒流的要求。

AC代码:

#include<iostream>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
const int N=6005;
const int INF=1e9+7;
int n,m;
int head[N];//和map组合存地图数据 
int num;
int vis[N];
int dis[N];//s到i的最短路径 
int enter[N]; 

struct Edge{//存地图数据
	int to,dis,next;
}map[N];

struct edge{ 
	int to,dis,from;
}Map[N];

void Clear()
{
	num=0;
	memset(head,-1,sizeof(head));
	memset(map,0,sizeof(map));
}
void add(int u,int v,int dis)
{
	map[num].to=v;
	map[num].dis=dis;
	map[num].next=head[u];
	head[u]=num++;
}
int spfa(int s)
{	
	memset(enter,0,sizeof(enter));
	memset(vis,0,sizeof(vis));
	fill(dis+1,dis+1+n,INF);
	queue<int>Q;
	while(!Q.empty()) Q.pop();
	vis[s]=1;
	dis[s]=0;
	Q.push(s);
	enter[s]=1;
	while(!Q.empty())
	{
		int v=Q.front();
		Q.pop();
		vis[v]=0;
		for(int k=head[v];k>-1;k=map[k].next)
			if(dis[map[k].to]>dis[v]+map[k].dis)//松弛条件 
			{
				dis[map[k].to]=dis[v]+map[k].dis;				
				if(!vis[map[k].to])
				{
					vis[map[k].to]=1;					
					enter[map[k].to]++;
					if(enter[map[k].to]>=n) return 1;//如果有负权,就出函数,否则会无限循环 
					Q.push(map[k].to);
				}
			}
	}
	return 0;
}
void input()
{
	int w;
	cin>>n>>m>>w;
	Clear();
	for(int i=0;i<m;i++)
	{
		cin>>Map[i].from>>Map[i].to>>Map[i].dis;
		add(Map[i].from,Map[i].to,Map[i].dis);
		add(Map[i].to,Map[i].from,Map[i].dis);
	}
	for(int i=0;i<w;i++)
	{
		cin>>Map[i].from>>Map[i].to>>Map[i].dis;
		add(Map[i].from,Map[i].to,-Map[i].dis);//注意,这里单向距离是要写入负值 
	}
}
void spfa_solve(int s) 
{
	if(spfa(s)) cout<<"YES"<<endl;
	else cout<<"NO"<<endl;
}
int main() 
{
	int T;
	cin>>T;
	while(T--)
	{
		input();
		spfa_solve(1);		
	}
	return 0;
} 
发布了247 篇原创文章 · 获赞 53 · 访问量 7万+

猜你喜欢

转载自blog.csdn.net/qq_42391248/article/details/89428865
今日推荐