POJ - 3259 ——Wormholes (空间旅行判负环)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.


题意:M条双向小路,W个单向虫洞,虫洞可以回到过去。(判负环)

思路:bellman+优先队列+邻接表。(spfa)
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn=500+5;
const int maxe=6000+5;
const int INF=0x7fffffff;

struct proc
{
    int v,w;
    int next;
};

proc edge[maxe];
int dis[maxn],vis[maxn],f,n,m,w,head[maxe];
int cnt[maxn];

int k;
void addEdge(int u,int v,int w)
{
    edge[k].v=v;
    edge[k].w=w;
    edge[k].next=head[u];
    head[u]=k++;
}

bool spfa()
{
    for(int i=0;i<=n;i++)
    {
        dis[i]=INF;
    }
    memset(cnt,0,sizeof(cnt));
    memset(vis,0,sizeof(vis));
    queue<int> q;
    vis[1]=1;
    dis[1]=0;
    cnt[1]=1;
    q.push(1);
    while(!q.empty())
    {
        int cur=q.front();
        q.pop();
        vis[cur]=false;
        for(int i=head[cur];i+1;i=edge[i].next)
        {
            int id=edge[i].v;
            if(dis[cur]+edge[i].w<dis[id])
            {
                dis[id]=dis[cur]+edge[i].w;
                if(!vis[id])
                {
                    cnt[id]++;
                    if(cnt[cur]>=n)
                        return false;
                    vis[id]=true;
                    q.push(id);
                }
            }
        }
    }
    return true;
}

int main()
{
    while(~scanf("%d",&f))
    {
        while(f--)
        {
            scanf("%d %d %d",&n,&m,&w);
            k=0;
            memset(head,-1,sizeof(head));
            int s,e,val;
            for(int i=0;i<m;i++)
            {
                scanf("%d %d %d",&s,&e,&val);
                addEdge(s,e,val);
                addEdge(e,s,val);
            }
            for(int i=0;i<w;i++)
            {
                scanf("%d %d %d",&s,&e,&val);
                addEdge(s,e,0-val);
            }
            if(spfa()) printf("NO\n");
            else printf("YES\n");
        }
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/80249855
今日推荐