Wormholes POJ - 3259

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题解:John的农场里field块地,path条路连接两块地,hole个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。我们的任务是知道会不会在从某块地出发后又回来,看到了离开之前的自己。

         可以通过枚举的方法,然后来逐个判断有没有负权边。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
int n,m,w,l,flag;
int e[5000][5000],dis[5000];
struct node
{
    int st,ed,sum;
} mp[30000];
void BellmanFord()
{
    int i,j;
    for(i=0; i<n-1; i++)//n-1次松弛
        for(j=0; j<l; j++)
        {
            if(dis[mp[j].ed]>dis[mp[j].st]+mp[j].sum)
                dis[mp[j].ed]=dis[mp[j].st]+mp[j].sum;        //松弛
        }
    for(i=0; i<l; i++)//看是否还能松弛
    {
        if(dis[mp[i].ed]>dis[mp[i].st]+mp[i].sum)
        {
            flag=1;
            break;
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&w);
        int i,j,a,b,c;
        l=0,flag=0;
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
                if(i==j)
                    e[i][i]=0;
                else
                    e[i][j]=inf;
        for(i=1; i<=n; i++)
            dis[i]=e[1][i];
        for(i=0; i<m; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            e[a][b]=e[b][a]=min(e[a][b],c);
        }
        for(i=0; i<w; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            e[a][b]=-c;
        }
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
            {
                if(i!=j&&e[i][j]!=inf)
                {
                    mp[l].st=i;
                    mp[l].ed=j;
                    mp[l++].sum=e[i][j];
                }
            }
        BellmanFord();
        if(flag) //说明还能能松弛,即有负权回路
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/GJLfly/article/details/81672544