poj 3259 Wormholes (判负环)

题目链接:http://poj.org/problem?id=3259

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

扫描二维码关注公众号,回复: 3859297 查看本文章

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

我用的floyd判负环,直接给代码。

说一下spfa判负环,spfa不能直接判负环,但是这个题不是直接给的负环。所以我们只需要用一个数组记录每个点出现的次数,如果大于n,则说明存在负环,因为正环只会判断一次。

#pragma GCC optimize(2)
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<set>
#include<vector>
#include<string>
#include<queue>
using namespace std;
const int maxn = 505;
const int inf = 0x3f3f3f3f;
typedef long long ll;
int dis[maxn][maxn];
int t;
int n, m, k;
int floyd()
{
	for (int p = 1; p <= n; p++)
	{
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				if (dis[i][j] > dis[i][p] + dis[p][j])
				{
					dis[i][j] = dis[i][p] + dis[p][j];
				}
			}
			if (dis[i][i] < 0)
			{
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	scanf("%d", &t);
	while (t--)
	{
		memset(dis, inf, sizeof(dis));
		scanf("%d%d%d", &n, &m, &k);
		for (int i = 0; i <= n; i++)
		{
			dis[i][i] = 0;
		}
		for (int i = 1; i <= m; i++)
		{
			int u, v, w;
			scanf("%d%d%d", &u, &v, &w);
			if (w < dis[u][v])
			{
				dis[u][v] = dis[v][u] = w;
			}
		}
		for (int i = 1; i <= k; i++)
		{
			int u, v, w;
			scanf("%d%d%d", &u, &v, &w);
			dis[u][v] = -w;
		}
		if (floyd())
		{
			printf("YES\n");
		}
		else
		{
			printf("NO\n");
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Evildoer_llc/article/details/83247550
今日推荐