1073 Scientific Notation

1073 Scientific Notation
Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [±][1-9].[0-9]+E[±][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent’s signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:
Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent’s absolute value is no more than 9999.

Output Specification:
For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:
+1.23400E-03
Sample Output 1:
0.00123400
Sample Input 2:
-1.2E+10
Sample Output 2:
-12000000000
题目大意:给定由科学计数法表示的数字,现在把它转换为普通数字表示法表示的数字,并且保存所有有效位,包括后面的0.
参考代码:

#include<iostream>
#include<string>
using namespace std;
int main() {
	int flag = 1, flag1 = 1, pe, E;
	string num, number, expopart;
	cin >> num;
	if (num[0] == '+')flag = 0;
	for (int i = 0; i < num.size(); i++) {   //找到E的位置,区分number portion与exponent portion
		if (num[i] == 'E') {
			pe = i;
			if (num[i + 1] == '+')flag1 = 0;
			break;
		}
	}
	number = num.substr(1, pe - 1);    //数字部分
	expopart = num.substr(pe + 2);     //指数部分
	E = stoi(expopart);
	if (flag)cout << "-";
	if (E == 0)cout << number;         //原数输出
	else if (flag1) {                  //正数,分三部分输出
		cout << "0.";
		for (int i = 1; i <= E - 1; i++)
			cout << "0";
		for (auto val : number)
			if (val != '.')cout << val;
	}
	else {                            //负数
		cout << number[0];
		string temp = number.substr(2);
		int len = temp.size();
		while (temp.size()<E){temp += "0";}
		if (len > E)temp.insert(E, ".");
		cout << temp;
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/82933802