HDU1241 Oil Deposits【DFS】

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43426    Accepted Submission(s): 25229


 

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

 Sample Output

0
1
2
2

Source

Mid-Central USA 1997

扫描二维码关注公众号,回复: 3511931 查看本文章

问题链接:HDU1241 Oil Deposits

问题描述:给你一个地图,找出所有不相连(八个方向)的@组合有多少个

解题思路:顺序遍历地图,如果当前点是'@'符号,则结果加一,并用bfs让与其相连的'@'全变为'*'

AC的C++代码:

#include<iostream>

using namespace std;
const int N=105;
char a[N][N];
int n,m;

struct DIR{
	int x,y;
}d[8]={{-1,0},{1,0},{0,-1},{0,1},{1,-1},{1,1},{-1,-1},{-1,1}};

void dfs(int x,int y)
{
	a[x][y]='*';
	for(int i=0;i<8;i++){
		int fx=x+d[i].x;
		int fy=y+d[i].y;
		if(0<fx&&fx<=m&&0<fy&&fy<=n&&a[fx][fy]=='@')
		  dfs(fx,fy);
	}
}

int main()
{
	while(~scanf("%d%d",&m,&n)&&(m||n)){
		for(int i=1;i<=m;i++)
		  for(int j=1;j<=n;j++)
		    scanf(" %c",&a[i][j]);
		int cnt=0;
		for(int i=1;i<=m;i++)
		  for(int j=1;j<=n;j++)
		    if(a[i][j]=='@'){
		    	cnt++;
		    	dfs(i,j);
			}
		printf("%d\n",cnt);
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/82873946