[HDU-1241]Oil Deposits【dfs】

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47453 Accepted Submission(s): 27282

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0

Sample Output
0
1
2
2

Source
Mid-Central USA 1997

Recommend
Eddy

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1241

简述:给出m行n列的字符,如果为’*‘则表示没油,如果是’@‘则表示有油,当’@‘周围八个位置也有’@'的时候,该两个为同一片油田,输出有多少个油田。

分析:当搜索到’@‘时则搜索它周围的八个位置,当越界或者无法走的时候返回,搜过的点标记为’!’。

说明:一开始开头跟主函数同时定义m, n导致了错误。。。

AC代码如下:

#include <iostream>
#include <string>
using namespace std;
char map[101][101];
int n, m;
void dfs(int i, int j)
{
	//如果搜索越界了或者无法走
	if (map[i][j] != '@' || i < 0 || i >= m || j < 0 || j >= n) return;
	else
	{
		map[i][j] = '!';//标记已经走过的路
		dfs(i - 1, j - 1);
		dfs(i - 1, j);
		dfs(i - 1, j + 1);
		dfs(i , j - 1);
		dfs(i , j + 1);
		dfs(i + 1, j - 1);
		dfs(i + 1, j);
		dfs(i + 1, j + 1);
	}
}
int main()
{
	int i, j, sum; //不能开头跟主函数同时定义m, n
	while (cin >> m >> n && m!=0 && n!=0)
	{
		sum = 0;
		for (i = 0; i < m; i++)
		{
			for (j = 0; j < n; j++)
			{
				cin >> map[i][j];
			}
		}
		for (i = 0; i < m; i++)
		{
			for (j = 0; j < n; j++)
			{
				if (map[i][j] == '@')
				{
					dfs(i, j);
					sum++;
				}
			}
		}
		cout << sum << endl;
	}
}

猜你喜欢

转载自blog.csdn.net/qq_43966202/article/details/86689536