TOJ 2865 Chopsticks DP

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/TheWise_lzy/article/details/81432169

2865: Chopsticks

描述

In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses a set of three chopsticks -- one pair, plus an EXTRA long chopstick to get some big food by piercing it through the food. As you may guess, the length of the two shorter chopsticks should be as close as possible, but the length of the extra one is not important, as long as it's the longest. To make things clearer, for the set of chopsticks with lengths A,B,C(A<=B<=C), (A-B)^2 is called the 'badness' of the set.

It's December 2nd, Mr.L's birthday! He invited K people to join his birthday party, and would like to introduce his way of using chopsticks. So, he should prepare K+8 sets of chopsticks(for himself, his wife, his little son, little daughter, his mother, father, mother-in-law, father-in-law, and K other guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find a way of composing the K+8 sets, so that the total badness of all the sets is minimized.

输入

The first line in the input contains a single integer T, indicating the number of test cases(1<=T<=20). Each test case begins with two integers K, N(0<=K<=1000, 3K+24<=N<=5000), the number of guests and the number of chopsticks. There are N positive integers Li on the next line in non-decreasing order indicating the lengths of the chopsticks.(1<=Li<=32000).

输出

For each test case in the input, print a line containing the minimal total badness of all the sets.

样例输入

1
1 40
1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98 103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164

样例输出

23

提示

For the sample input, a possible collection of the 9 sets is:
8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160

题意:L先生要从n根筷子从挑出k+8对,而他的筷子,一对有3根筷子abc组成,其中c为最长的,(a-b)*(a-b)构成了这对筷子的badness值,求构成k+8对筷子的最小badness值。

思路:因为要求c是最大的,而且有ab构成badness值,所以可以把整个数组从大到小排列,数组dp[i][j]构成了i根筷子中选j对。

转移方程:f[i][j]=min(f[i-1][j],f[i-2][j-1]+(a[i]-a[i-1])*(a[i]-a[i-1]));

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int a[5500],f[5500][1500];
//f[i][j]表示前i个数中选j对
bool cmp(int x,int y)
{
	return x>y;
}
int main()
{
	int t,n,k,i,j;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        scanf("%d%d",&k,&n);
        for(i=1;i<=n;i++)
        scanf("%d",&a[i]);
        sort(a+1,a+n+1,cmp);
        for(i=1;i<=n;i++)
        {
            f[i][0]=0;
            for(j=1;j<=k+8;j++)
            f[i][j]=10000000;
        }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=k+8;j++)
            {
                if(3*j<=i)
                f[i][j]=min(f[i-1][j],f[i-2][j-1]+(a[i]-a[i-1])*(a[i]-a[i-1]));
            }
        }
        printf("%d\n",f[n][k+8]);
    }
}

猜你喜欢

转载自blog.csdn.net/TheWise_lzy/article/details/81432169
今日推荐