Hopscotch

Hopscotch

时间限制: 5 Sec 内存限制: 128 MB

题目描述

You’re playing hopscotch! You start at the origin and your goal is to hop to the lattice point (N, N). A hop consists of going from lattice point (x1, y1) to (x2, y2), where x1 < x2 and y1 < y2.
You dislike making small hops though. You’ve decided that for every hop you make between two lattice points, the x-coordinate must increase by at least X and the y-coordinate must increase by at least Y .
Compute the number of distinct paths you can take between (0, 0) and (N, N) that respect the above constraints. Two paths are distinct if there is some lattice point that you visit in one path which you don’t visit in the other.
Hint: The output involves arithmetic mod 109+ 7. Note that with p a prime like \(10^9+ 7\), and x an integer not equal to 0 mod p, then \(x(x^p−2)\) mod \(p\) equals 1 mod p.

输入

The input consists of a line of three integers, N X Y . You may assume 1 ≤ X, Y ≤ N ≤ \(10^6\).

输出

The number of distinct paths you can take between the two lattice points can be very large. Hence output this number modulo 1 000 000 007 \((10^9+ 7)\).

样例输入

7 2 3

样例输出

9

题意

从坐标\((0,0)\)走到\((n,n)\),每一步在横向向至少走X步,在纵向至少走Y步。问走到重点有多少种走法

分析

考虑走i步到达终点的方法数,即等于分别从横向和纵向走到坐标为n处的方法数乘积。
以横向为例,用\(dp[i]\)表示从\(x=0\)处走到\(x=n\)处恰好走了i步的方法数。这其实相当于这样一个问题:把n个相同的球分给i个不同的人,每个人至少X个球,问有多少种分法。
可以先每个人分\(X-1\)个球,然后还剩余\(n-(X-1) \times i\)个球,对于剩下的球使用隔板法,分球方法数为\(C_{n-(X-1)\times i}^{i-1}\);
最终结果就是\[ \sum_{i=1}^{ min(\frac{n}{X},\frac{n}{Y}) } C_{n-(X-1)\times i}^{i-1} C_{n-(Y-1)\times i}^{i-1}\]

代码

#include <cstdio>
#include <vector>
#include <algorithm>
#include <iostream>
typedef long long ll;
using namespace std;
ll mod = 1000000007;
const int maxn = 1000010;
 
ll qpow(ll a,ll x){
    ll ret=1;
    while (x){
        if (x&1)
            ret = ret*a%mod;
        a=a*a%mod;
        x>>=1;
    }
    return ret;
}
ll fac[maxn],inv[maxn];
 
ll init(){
    fac[0]=1;
    for (int i=1;i<maxn;i++)
        fac[i]=fac[i-1]*i%mod;
    inv[maxn-1]=qpow(fac[maxn-1],mod-2);
    for (int i=maxn-2;i>=0;i--)
        inv[i]=inv[i+1]*(i+1)%mod;
    return 0;
}
 
ll c(ll n,ll m){
    if (n<m) return 0;
    return fac[n]*inv[m]%mod*inv[n-m]%mod;
}
 
ll dp1[maxn],dp2[maxn];
 
 
int main() {
    init();
    ll n,x,y;
    scanf("%lld%lld%lld",&n,&x,&y);

    for (int i=1;i*x<=n;i++)
    {
        dp1[i]=c(n-(x-1)*i-1,i-1);
    }
 
    for (int i=1;i*y<=n;i++)
    {
        dp2[i]=c(n-(y-1)*i-1,i-1);
    }
 
    ll ans = 0;
    for (int i=1;i*x<=n&&i*y<=n;i++)
        ans =( ans + dp1[i]*dp2[i]%mod)%mod ;
 
    printf("%lld\n",ans);
 
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/sciorz/p/8904234.html