53 树状数组;

 N - Color the ball

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

Sample Input

3
1 1
2 2
3 3
3
1 1
1 2
1 3
0

Sample Output

1 1 1
3 2 1

这是最简单的树状数组区间更新;

这道题目我们后来碰到了变式,就是西安的拿到gcd题目就是统计一下每一个位置2,3的个数取得一个最小数字(个数),然后求算一个指数就可以得到结果了;

#include <stdlib.h>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
typedef long long ll;
const int Max = 1e6+10;

ll c[Max],n,m;

int lowbit(int x){
   return (x&-x);
}
void add(int x, int num){
      while(x<=n){
        c[x]+=num;
        x+=lowbit(x);
      }
}

ll query(int x){
   ll sum=0;
   while(x){
    sum+=c[x];
    x-=lowbit(x);
   }
   return sum;
}
int main(){
   while(scanf("%lld",&n)&&n){
      memset(c,0,sizeof(c));
     for(int i=1;i<=n;i++){
    ll u,v;
    scanf("%lld %lld",&u,&v);
    add(u,1);
    add(v+1,-1);
   }
   for(int i=1;i<=n;i++){
        if(i!=1)
        printf(" ");
    printf("%lld",query(i));
   }
   printf("\n");
   }
   return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39792342/article/details/83411595
53
今日推荐