【PAT乙级】1082 射击比赛

本题目给出的射击比赛的规则非常简单,谁打的弹洞距离靶心最近,谁就是冠军;谁差得最远,谁就是菜鸟。本题给出一系列弹洞的平面坐标(x,y),请你编写程序找出冠军和菜鸟。我们假设靶心在原点(0,0)。

输入格式:

输入在第一行中给出一个正整数 N(≤ 10 000)。随后 N 行,每行按下列格式给出:

ID x y

其中 ID 是运动员的编号(由 4 位数字组成);x 和 y 是其打出的弹洞的平面坐标(x,y),均为整数,且 0 ≤ |x|, |y| ≤ 100。题目保证每个运动员的编号不重复,且每人只打 1 枪。

输出格式:

输出冠军和菜鸟的编号,中间空 1 格。题目保证他们是唯一的。

输入样例:

3
0001 5 7
1020 -1 3
0233 0 -1

输出样例:

0233 0001

个人理解

水题略过

代码实现

#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <cmath>
#include <algorithm>
#include <iostream>
#define ll long long
#define ep 1e-5
#define INF 0x7FFFFFFF

const int maxn = 10005;

using namespace std;

struct Athelete {
    int id;
    double distance;
};
Athelete athes[maxn];

bool cmp(Athelete a1, Athelete a2) {
    return a1.distance < a2.distance;
}

int main() {
    int n;
    cin >> n;
    
    for (int i = 0; i < n; i ++) {
        int id, x, y;
        cin >> id >> x >> y;
        athes[i].id = id;
        athes[i].distance = sqrt(x*x + y*y);
    }
    
    sort(athes, athes+n, cmp);
    
    printf("%04d %04d", athes[0].id, athes[n-1].id);
    
    return 0;
}

总结

学习不息,继续加油

猜你喜欢

转载自blog.csdn.net/qq_34586921/article/details/83475066