PAT~乙级~1082 射击比赛 ~python

题目描述:

本题目给出的射击比赛的规则非常简单,谁打的弹洞距离靶心最近,谁就是冠军;谁差得最远,谁就是菜鸟。本题给出一系列弹洞的平面坐标(x,y),请你编写程序找出冠军和菜鸟。我们假设靶心在原点(0,0)。

输入格式:

输入在第一行中给出一个正整数 N(≤ 10 000)。随后 N 行,每行按下列格式给出:

ID x y

其中 ID 是运动员的编号(由 4 位数字组成);x 和 y 是其打出的弹洞的平面坐标(x,y),均为整数,且 0 ≤ |x|, |y| ≤ 100。题目保证每个运动员的编号不重复,且每人只打 1 枪。

输出格式:

输出冠军和菜鸟的编号,中间空 1 格。题目保证他们是唯一的。

输入样例:

3
0001 5 7
1020 -1 3
0233 0 -1

输出样例:

0233 0001

----------------------------------------------------------答题区----------------------------------------------------------

num = int(input())
first = ''
first_score = float('inf')
last = ''
last_score = 0
for i in range(num):
    s = input().split()
    score = int(s[1])**2+int(s[2])**2
    if(score > last_score):
        last_score = score
        last = s[0]
    if(score < first_score):
        first_score = score
        first = s[0]
print(first,last)

 已经考完了乙级,虽然结果不是很理想,大家可以看一下我的经验贴https://blog.csdn.net/qq_40612211/article/details/100973477。

维护了一个PAT测试点问题的共享文档,欢迎大家把遇到的问题写在上面。

一起写文档:https://yiqixie.com/d/home/fcACe6xZ2aroPxFQrQZ05Cw32
github链接:https://github.com/Makerdd/PAT-yiji

发布了119 篇原创文章 · 获赞 5 · 访问量 5022

猜你喜欢

转载自blog.csdn.net/qq_40612211/article/details/101174929