PAT-1079 延迟的回文数

1079 延迟的回文数 (20 分)

给定一个 k+1 位的正整数 N,写成 a​k​​⋯a​1​​a​0​​ 的形式,其中对所有 i 有 0≤a​i​​<10 且 a​k​​>0。N 被称为一个回文数,当且仅当对所有 i 有 a​i​​=a​k−i​​。零也被定义为一个回文数。

非回文数也可以通过一系列操作变出回文数。首先将该数字逆转,再将逆转数与该数相加,如果和还不是一个回文数,就重复这个逆转再相加的操作,直到一个回文数出现。如果一个非回文数可以变出回文数,就称这个数为延迟的回文数。(定义翻译自 https://en.wikipedia.org/wiki/Palindromic_number

给定任意一个正整数,本题要求你找到其变出的那个回文数。

输入格式:

输入在一行中给出一个不超过1000位的正整数。

输出格式:

对给定的整数,一行一行输出其变出回文数的过程。每行格式如下

A + B = C

其中 A 是原始的数字,BA 的逆转数,C 是它们的和。A 从输入的整数开始。重复操作直到 C 在 10 步以内变成回文数,这时在一行中输出 C is a palindromic number.;或者如果 10 步都没能得到回文数,最后就在一行中输出 Not found in 10 iterations.

输入样例 1:

97152

输出样例 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

输入样例 2:

196

输出样例 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.
#include<iostream>
using namespace std;
bool is(string str)
{
  int l=str.length();
  for(int i=0;i<l/2;i++)
  {
    if(str[i]!=str[l-1-i])
    {
      return false;
    }
  }
  return true;
}
int main()
{
	int count=0;
	string str;
	cin>>str;
	if(is(str))
	{
		cout<<str<<" is a palindromic number.";
		return 0;
	}
	while(1)
	{
		if(count==10)
		{
			cout<<"Not found in 10 iterations.";
			break;
		}
		string str1,str2;
		str1=str2=str;
		int c;
		int m=str.length();
		for(int i=0;i<m;i++)
    {
      c=str[m-1-i]-'0';
      str1[i]=c+'0';
    }
		c=0;
		for(int i=0;i<str.length();i++)
		{
			c=c+str[i]-'0'+str1[i]-'0';
			str2[i]=c%10+'0';
			c/=10;
		}
		if(c!=0)
		{
			str2+=c+'0';
		}
		int e=str2.length();
		for(int i=0;i<e/2;i++)
		{
			char k=str2[i];
			str2[i]=str2[e-i-1];
			str2[e-1-i]=k;
		}
		cout<<str<<" + "<<str1<<" = "<<str2<<endl;
		str=str2;
		if(is(str))
		{
			cout<<str<<" is a palindromic number.";
			break;
		}
		count++;
	}
	return 0;
}

 注意要用string来保存数字,而且在进位的计算也要注意

猜你喜欢

转载自blog.csdn.net/qq_42020563/article/details/84073302