PAT (Advanced Level) Practice 1145 Hashing - Average Search Time (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

 题意:
给定一个哈希表的大小,一段序列,和哈希函数,求给定一个序列,将其构造成哈希表,并求每次查找的平均次数。

思路:
根据题目要求构造哈希表,并进行查找。

代码如下:

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5+10;
int Msize,n,m;
int Hash[maxn];
map<int,int>ma;
bool Judge (int x)
{
	if(x==1)
		return false;
	for (int i=2;i<=sqrt(x);i++)
	{
		if(x%i==0)
		{
			return false;
		}
	}
	return true;
}
int main()
{
	memset (Hash,-1,sizeof(Hash));
	scanf("%d%d%d",&Msize,&n,&m);
	while (!Judge(Msize))
	{
		Msize++;
	}
	for (int i=0;i<n;i++)
	{
		int x;
		scanf("%d",&x);
		int loc=x%Msize;
		int flag=0;
		for (int j=0;j<Msize;j++)
		{
			int nloc=(loc+j*j)%Msize;
			if(Hash[nloc]==-1)
			{
				Hash[nloc]=x;
				flag=1;
				break;
			}
		}
		if(!flag)
		{
			printf("%d cannot be inserted.\n",x);
		}
	}
	int sum=0,t=m;
	double ans;
	for (int i=0;i<m;i++)
	{
		int x;
		scanf("%d",&x);
		int loc=x%Msize,tsum=0,flag=0;
		for (int j=0;j<Msize;j++)
		{
			int nloc=(loc+j*j)%Msize;
			//tsum++;
			sum++;
			if(Hash[nloc]==x||Hash[nloc]==-1)
			{
				flag=1;
				break;
			}
		}
		if(flag==0)
		{
			sum++;
		}
	}
	printf("%.1lf\n",sum*1.0/m);
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/84863566