1145 Hashing - Average Search Time (25 分)哈希平方探查法

1145 Hashing - Average Search Time (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted.where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

学习来自https://blog.csdn.net/ysq96/article/details/81748064

其中:

                 哈希函数构造方法:H(key) = key % TSize (除留余数法)
                 处理冲突方法:Hi = (H(key) + di) % TSize (开放地址发——二次方探测再散列)

                 其中di为 1*1 , -1*1 , 2*2 , -2*2 , ··· k*k , -k*k (k <= MSize-1)
 

//MSisze 定义的表大小 N输入个数 M需要查询的键
//n个数
//m个数  每个数不超过10的五次
//如果允许插入字符 输出..
//最后输出平均搜索时间对于M个key 保留一位小数
//tablesize最好是素数 如果不是重新定义稍微大一些的素数 

#include<iostream>
#include<vector>
using namespace std;
const int maxn=10010; 
bool is_prime(int n)
{
	for(int i=2;i*i<=n;i++)
	if(n%i==0)
	return false;
	return true;
}
int main()
{
	int msize,n,m,x;
	cin>>msize>>n>>m;
	while(is_prime(msize)==false)
	{
		msize++;
	}
	//cout<<msize;
	vector<int>v(msize);//建表 
	for(int i=0;i<n;i++)
	{
		scanf("%d",&x);
		int flag=0;
		for(int j=0;j<msize;j++)
		{//平方探测法(正向) 
			int pos=(x+j*j)%msize;
			if(v[pos]==0)
			{
				v[pos]=x;
				flag=1;
				break;
			}
		}
		if(!flag)
		printf("%d cannot be inserted.\n",x);
	}
	double ans=0;
	for(int i=0;i<m;i++)
	{
		scanf("%d",&x);
		int time=1;
		for(int j=0;j<msize;j++)
		{
			int pos=(x+j*j)%msize;
			if(v[pos]==0||v[pos]==x)
			break;
			time++;
		}
		ans+=time;
	} 
	printf("%.1f\n",ans/m);
} 

猜你喜欢

转载自blog.csdn.net/qq_40916491/article/details/88061082