hdu3018 一笔画画几次

Ant Trip

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4712    Accepted Submission(s): 1849


 

Problem Description

Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country. 

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.

 

Input

Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.

 

Output

For each test case ,output the least groups that needs to form to achieve their goal.

 

Sample Input

 

3 3 1 2 2 3 1 3 4 2 1 2 3 4

 

Sample Output

 

1 2

Hint

New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.

 

Source

2009 Multi-University Training Contest 12 - Host by FZU

 

Recommend

gaojie   |   We have carefully selected several similar problems for you:  3013 3015 3016 3011 3010 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 100005
using namespace std;
int father[maxn];
int odd[maxn];
int num[maxn];
int degree[maxn];
int find(int x)
{
    if(father[x]!=x)
        father[x]=find(father[x]);
    return father[x];
}
void unionn(int u,int v)
{
    int a=find(u);
    int b=find(v);
    if(a!=b)
        father[a]=b;
}
int n,m;
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<=n;i++)
        father[i]=i;
        memset(degree,0,sizeof(degree));
        memset(num,0,sizeof(num));
        memset(odd,0,sizeof(odd));
        while(m--)

        {
            int u,v;
            scanf("%d%d",&u,&v);
            degree[u]++;
            degree[v]++;
            unionn(u,v);
        }
        for(int i=1;i<=n;i++)
        {
            num[find(i)]++;
            if(degree[i]%2)
            odd[find(i)]++;

        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            if(num[i]<=1)
                continue;
           else if(odd[i]==0)
            ans++;
           else if(odd[i]>0)
            ans+=odd[i]/2;
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/86010051