PTAL2-011 玩转二叉树解题报告---二叉树的重建

版权声明:转载请注明出处:https://blog.csdn.net/qq1013459920 https://blog.csdn.net/qq1013459920/article/details/85341966

                                        L2-011 玩转二叉树 (25 分)

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2

 二叉树重建

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<queue>
#include<climits>
#include<set>
#include<stack>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
static const int MAX_N = 1e4 + 5;
int inorder[35], preorder[35];
struct Node{
	int lch;
	int rch;
	int weight;
};
Node Child[MAX_N];
int cnt;
void build(int L, int R, int rt) {
	if (L >= R) {
		Child[rt].weight = 0;
		return;
	}
	int root = preorder[cnt++];
	Child[rt].lch = rt << 1;
	Child[rt].rch = rt << 1 | 1;
	Child[rt].weight = root;
	int mid = find(inorder, inorder + R, root) - inorder;
	build(L, mid, rt << 1);
	build(mid + 1, R, rt << 1 | 1);
}
void bfs() {
	queue<int> Q;
	Q.push(1);
	while (!Q.empty()) {
		int rt = Q.front();
		Q.pop();
		if (Child[rt].weight) {
			if (rt != 1) printf(" ");
			printf("%d", Child[rt].weight);
			Q.push(Child[rt].rch);
			Q.push(Child[rt].lch);
		}
	}
	printf("\n");
}
int main() {
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++) Child[i].weight = 0;
	for (int i = 0; i < n; i++) scanf("%d", &inorder[i]);
	for (int i = 0; i < n; i++) scanf("%d", &preorder[i]);
	build(0, n, 1);
	bfs();
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq1013459920/article/details/85341966