PAT (Advanced Level) Practice A1050 String Subtraction (20 分)(C++)(甲级)(散列)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86487952

1050 String Subtraction (20 分)
Given two strings S1 and S​2 , S=S​1−S2 is defined to be the remaining string after taking all the characters in S​2​​ from S1. Your task is simply to calculate S1 −S​2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1 and S​2 , respectively. The string lengths of both strings are no more than 10​4 . It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1 −S​2in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.


using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>


int main()
{
    int ASCII[200] = {0};//ASCII码一共有一百多个字符
    string str1, str2;
    getline(cin, str1);
    getline(cin, str2);
    int len1 = str1.length();
    int len2 = str2.length();
    for(int i=0; i<len2; i++) ASCII[str2[i]] = 1;//若str2中有字符则将其位置标志置一
    for(int i=0; i<len1; i++)
    {
        if(ASCII[str1[i]]) continue;
        printf("%c", str1[i]);//str1中无str2的字符则正常输出即可
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86487952