【PAT甲级】1050 String Subtraction (20)

题目链接

Given two strings S~1~ and S~2~, S = S~1~ - S~2~ is defined to be the remaining string after taking all the characters in S~2~ from S~1~. Your task is simply to calculate S~1~ - S~2~ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S~1~ and S~2~, respectively. The string lengths of both strings are no more than 10^4^. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S~1~ - S~2~ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <map>
#include <stack>
#include <cmath>
#include <vector>
#include <sstream>
#include <algorithm>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define mem(a,n) memset(a,n,sizeof(a))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const int N = 1e4+5;


map<int,bool>mp;
char str1[N],str2[N];
int main() {
    fgets(str1,sizeof(str1),stdin);
    fgets(str2,sizeof(str2),stdin);
    for(int i=0; i<200; i++) mp[i]=0;
    int index=0;
    while(str2[index]!='\0') {
        mp[str2[index]]=1;
        index++;
    }
    rep(i,0,strlen(str1)) {
        if(!mp[str1[i]]) putchar(str1[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/81349141