1050 String Subtraction(20 分)

1050 String Subtraction(20 分)

Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1​​−S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

代码如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	set<char > s;
	string a,b;
	getline(cin,a);
	getline(cin,b);
	for(int i=0;i<b.size();i++)
	{
		s.insert(b[i]);
	}
	for(int i=0;i<a.size();i++)
	{
		if(s.find(a[i])==s.end())
		{
			cout<<a[i];
		}
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/qq_41113002/article/details/82387075