1050 String Subtraction (20 分)哈希 map

1050 String Subtraction (20 分)

Given two strings S1​​ and S2​​, S=S1​​S2​​ is defined to be the remaining string after taking all the characters in S2​​ from S1​​. Your task is simply to calculate S1​​S2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1​​ and S2​​, respectively. The string lengths of both strings are no more than 104​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1​​S2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
#include<set>
#include<stack>
#include<string.h>
#include<cstdio>
using namespace std;

map<char,int>mp;
char ch1[10005],ch2[10004];

int main()
{
    char ch;
    scanf("%c",&ch);
    int i,len1,len2;
    for(i=0; ch!='\n'; i++)
    {
        ch1[i]=ch;
        mp[ch]=1;
        scanf("%c",&ch);

    }
    len1=i;
    scanf("%c",&ch);
    for(i=0; ch!='\n'; i++)
    {
        ch2[i]=ch;
        mp[ch]=0;
        scanf("%c",&ch);
       // mp[ch]=1;

    }
    len2=i;
    for(int i=0; i<len1; i++)
    {
        if(mp[ch1[i]]==1)
            printf("%c",ch1[i]);
    }
    //cout<<len2<<len1;
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/zhanghaijie/p/10315963.html