1050. String Subtraction (20)-PAT甲级真题(哈希)

1050. String Subtraction (20)-PAT甲级真题(哈希)

Given two strings S1 and S2, S = S1 – S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 – S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 – S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
题目大意:给出两个字符串,在第一个字符串中删除第二个字符串中出现过的所有字符并输出~

分析:用arr[256]数组变量标记str2出现过的字符>=1,输出str1的时候根据arr[str1[i]]是否为0来输出

#include<iostream>
#include<stdio.h>
#include<map>
#include<string.h>
using namespace std;

int main(){
	char s1[10001];
	cin.getline(s1,10001);
	
	int arr[255] = {0};
	while(char ch = getchar())
	{
		if(ch == '\n')
			break;
		arr[ch]++;	
	}	
	
	string res = "";
	for(int i=0;i<strlen(s1);i++)
		if(arr[s1[i]] == 0)
			res += s1[i];
	cout<<res<<endl;
	
	return 0;
}

 写法二:

#include<iostream>
#include<stdio.h>
#include<map>
using namespace std;

int main(){
	string s1;
	getline(cin,s1);
	
	int arr[255] = {0};
	while(char ch = getchar())
	{
		if(ch == '\n')
			break;
		arr[ch]++;	
	}	
	
	string res = "";
	for(int i=0;i<s1.size();i++)
		if(arr[s1[i]] == 0)
			res += s1[i];
	cout<<res<<endl;
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/82501000