1050 String Subtraction (20 分)

Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1​​−S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

题目大意:给出两个字符串,在第一个字符串中删除第二个字符串中出现过的所有字符并输出

使用int lens1 = strlen(s1);int lens2 = strlen(s2);的形式for套for,铁定超时,除非我吃拧了这么干

打个flag标记就行,跑一遍标记OK了

使用gets前面请使用char str[100000]而非char *str~~,比较讲究

#include <iostream>
#include <string>
using namespace std;
string s1, s2;
int main() {
    getline(cin,s1);getline(cin,s2);
    int lens1 = s1.length(), lens2 = s2.length();
    int flag[256] = {0};
    for(int i = 0; i < lens2; i++)
        flag[s2[i]] = 1;
    for(int i = 0; i < lens1; i++) {
        if(!flag[s1[i]])
            printf("%c", s1[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/mlm5678/article/details/83067305