1050 String Subtraction (20 分) map

Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1​​−S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

题意

给两个字符串s1,s2求s1去掉s2中的字符后的字符串。

思路:

用map记下s2中的字符,然后再对s1中的字符s2是否存在。

输入用的cin.getline();

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <map>
#include <string>
using namespace std;
const int maxn=1e4+5;
char s1[maxn],s2[maxn];
map<char,int>ma;
int main()
{
    cin.getline(s1,maxn);
    cin.getline(s2,maxn);
    int len1=strlen(s1),len2=strlen(s2);
    for (int i=0;i<len2;i++)
        ma[s2[i]]=1;
    for (int i=0;i<len1;i++)
    {
        if(!ma[s1[i]])
            printf("%c",s1[i]);
    }
    printf("\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/84112975