1050 String Subtraction (20 分)

1050 String Subtraction (20 分)

Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1​​−S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

解题思路:1.ASCII码工128个 十进制由0-127 因此用一个128大小的数组存足以

2.注意输入函数:getline(cin,str)可以接收空格,换行符结束;而普通cin和getline都不能接受空格

3.如果使用erase函数,i会改变,不妥

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

int vis[128];//ASCII码工128个字符 十进制0到127

int main()
{
    string s1,s2,ans;
    getline(cin,s1);
    getline(cin,s2);
    memset(vis,0,sizeof(vis));
    for(int i = 0; i < s2.size(); i++){
        vis[s2[i]] = 1;
    }
    for(int i = 0; i < s1.size(); i++){
        if(!vis[s1[i]]){
            ans += s1[i];
        }
    }
    cout << ans;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_36313227/article/details/89022938